based on yesterdays topology upload , some modifications being made as Jeremy didn't advertise the external route link to internal
for some reason I can't attach files so I just pasted those here
R1 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.13.1 255.255.255.0
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.0.0 0.0.255.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 5500
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R4 configs
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.34.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
ip address 10.1.45.1 255.255.255.0
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.24.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 5500
neighbor 1.1.1.1 update-source Loopback4
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 6500
neighbor 5.5.5.5 ebgp-multihop 5
neighbor 10.1.45.2 remote-as 6500
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R5 configs
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.34.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
ip address 10.1.45.1 255.255.255.0
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.24.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 5500
neighbor 1.1.1.1 update-source Loopback4
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 6500
neighbor 5.5.5.5 ebgp-multihop 5
neighbor 10.1.45.2 remote-as 6500
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
topology file same as previous
autostart = False
[127.0.0.1:7200]
workingdir = working
udp = 10000
[[2691]]
image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
idlepc = 0x62283bc8
ghostios = True
[[ROUTER R4]]
model = 2691
console = 2003
aux = 2100
cnfg = configs\R4.cfg
wic0/0 = WIC-2T
wic0/1 = WIC-2T
s0/0 = R2 s0/1
s0/1 = R3 s0/1
s0/2 = R5 s0/0
x = -52.0
y = -14.0
[[ROUTER R1]]
model = 2691
console = 2000
aux = 2101
cnfg = configs\R1.cfg
wic0/0 = WIC-2T
wic0/1 = WIC-2T
s0/0 = R2 s0/0
s0/1 = R3 s0/0
x = -172.0
y = -149.0
[[ROUTER R2]]
model = 2691
console = 2001
aux = 2102
cnfg = configs\R2.cfg
wic0/0 = WIC-2T
s0/0 = R1 s0/0
s0/1 = R4 s0/0
x = -186.0
y = -14.0
[[ROUTER R3]]
model = 2691
console = 2002
aux = 2103
cnfg = configs\R3.cfg
wic0/0 = WIC-2T
s0/0 = R1 s0/1
s0/1 = R4 s0/1
x = -42.0
y = -152.0
[127.0.0.1:7201]
workingdir = working
udp = 10100
[[2691]]
image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
idlepc = 0x62283bc8
ghostios = True
[[ROUTER R5]]
model = 2691
console = 2004
aux = 2104
cnfg = configs\R5.cfg
wic0/0 = WIC-2T
s0/0 = R4 s0/2
x = 163.0
y = -162.0
[GNS3-DATA]
configs = configs
workdir = working
[[NOTE 1]]
text = AS6500
x = 181.0
y = -67.0
[[NOTE 2]]
text = AS 5500
x = -163.0
y = 127.0
[[NOTE 3]]
text = s0/0
x = -6.47356356195
y = 28.4682130238
interface = R3 s0/0
[[NOTE 4]]
text = s0/1
x = 35.3915084294
y = 61.9284445907
interface = R3 s0/1
[[NOTE 5]]
text = s0/0
x = 31.7593438286
y = -17.9807550237
interface = R2 s0/0
[[NOTE 6]]
text = s0/1
x = 72.6315721092
y = 16.5834981624
interface = R2 s0/1
[[NOTE 7]]
text = s0/1
x = 72.473563562
y = 15.5317869762
interface = R1 s0/1
[[NOTE 8]]
text = s0/0
x = 34.2406561714
y = 61.9807550237
interface = R1 s0/0
[[NOTE 9]]
text = s0/0
x = 1.84437745212
y = 47.0863943933
interface = R5 s0/0
[[NOTE 10]]
text = s0/2
x = 64.1556225479
y = -3.08639439326
interface = R4 s0/2
[[NOTE 11]]
text = s0/1
x = 30.6084915706
y = -17.9284445907
interface = R4 s0/1
[[NOTE 12]]
text = s0/0
x = -6.63157210916
y = 27.4165018376
interface = R4 s0/0
[[SHAPE 1]]
type = ellipse
x = -208.0
y = -192.0
width = 263.0
height = 296.0
border_style = 2
z = -2.0
for some reason I can't attach files so I just pasted those here
R1 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.12.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.13.1 255.255.255.0
clock rate 2000000
!
interface Serial0/2
no ip address
shutdown
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.1.0.0 0.0.255.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 5500
neighbor 4.4.4.4 update-source Loopback1
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R4 configs
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.34.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
ip address 10.1.45.1 255.255.255.0
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.24.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 5500
neighbor 1.1.1.1 update-source Loopback4
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 6500
neighbor 5.5.5.5 ebgp-multihop 5
neighbor 10.1.45.2 remote-as 6500
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R5 configs
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback4
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.24.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
ip address 10.1.34.2 255.255.255.0
clock rate 2000000
!
interface Serial0/2
ip address 10.1.45.1 255.255.255.0
clock rate 2000000
!
interface Serial0/3
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.1.23.0 0.0.0.255 area 0
network 10.1.24.0 0.0.0.255 area 0
network 10.1.34.0 0.0.0.255 area 0
!
router bgp 5500
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 5500
neighbor 1.1.1.1 update-source Loopback4
neighbor 1.1.1.1 next-hop-self
neighbor 5.5.5.5 remote-as 6500
neighbor 5.5.5.5 ebgp-multihop 5
neighbor 10.1.45.2 remote-as 6500
no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
topology file same as previous
autostart = False
[127.0.0.1:7200]
workingdir = working
udp = 10000
[[2691]]
image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
idlepc = 0x62283bc8
ghostios = True
[[ROUTER R4]]
model = 2691
console = 2003
aux = 2100
cnfg = configs\R4.cfg
wic0/0 = WIC-2T
wic0/1 = WIC-2T
s0/0 = R2 s0/1
s0/1 = R3 s0/1
s0/2 = R5 s0/0
x = -52.0
y = -14.0
[[ROUTER R1]]
model = 2691
console = 2000
aux = 2101
cnfg = configs\R1.cfg
wic0/0 = WIC-2T
wic0/1 = WIC-2T
s0/0 = R2 s0/0
s0/1 = R3 s0/0
x = -172.0
y = -149.0
[[ROUTER R2]]
model = 2691
console = 2001
aux = 2102
cnfg = configs\R2.cfg
wic0/0 = WIC-2T
s0/0 = R1 s0/0
s0/1 = R4 s0/0
x = -186.0
y = -14.0
[[ROUTER R3]]
model = 2691
console = 2002
aux = 2103
cnfg = configs\R3.cfg
wic0/0 = WIC-2T
s0/0 = R1 s0/1
s0/1 = R4 s0/1
x = -42.0
y = -152.0
[127.0.0.1:7201]
workingdir = working
udp = 10100
[[2691]]
image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
idlepc = 0x62283bc8
ghostios = True
[[ROUTER R5]]
model = 2691
console = 2004
aux = 2104
cnfg = configs\R5.cfg
wic0/0 = WIC-2T
s0/0 = R4 s0/2
x = 163.0
y = -162.0
[GNS3-DATA]
configs = configs
workdir = working
[[NOTE 1]]
text = AS6500
x = 181.0
y = -67.0
[[NOTE 2]]
text = AS 5500
x = -163.0
y = 127.0
[[NOTE 3]]
text = s0/0
x = -6.47356356195
y = 28.4682130238
interface = R3 s0/0
[[NOTE 4]]
text = s0/1
x = 35.3915084294
y = 61.9284445907
interface = R3 s0/1
[[NOTE 5]]
text = s0/0
x = 31.7593438286
y = -17.9807550237
interface = R2 s0/0
[[NOTE 6]]
text = s0/1
x = 72.6315721092
y = 16.5834981624
interface = R2 s0/1
[[NOTE 7]]
text = s0/1
x = 72.473563562
y = 15.5317869762
interface = R1 s0/1
[[NOTE 8]]
text = s0/0
x = 34.2406561714
y = 61.9807550237
interface = R1 s0/0
[[NOTE 9]]
text = s0/0
x = 1.84437745212
y = 47.0863943933
interface = R5 s0/0
[[NOTE 10]]
text = s0/2
x = 64.1556225479
y = -3.08639439326
interface = R4 s0/2
[[NOTE 11]]
text = s0/1
x = 30.6084915706
y = -17.9284445907
interface = R4 s0/1
[[NOTE 12]]
text = s0/0
x = -6.63157210916
y = 27.4165018376
interface = R4 s0/0
[[SHAPE 1]]
type = ellipse
x = -208.0
y = -192.0
width = 263.0
height = 296.0
border_style = 2
z = -2.0
I know this was years ago, but you posted the wrong config under R5 (R4's I again). IF you do happen to have the correct config, it would be nice if you could post it.
ReplyDeleteHaving trouble getting the lab to work, cannot ping any networks on R5, i'm getting U.U.U.U unreachables).
BR //Mike