Search This Blog

Sunday, April 10, 2011

basic BGP lab files per cbt nugget Jeremy 642-902

BGP topo anyone?

well... I simulated Jeremy's basic bgp

here is the conf s
topology file
autostart = False
[127.0.0.1:7200]
    workingdir = working
    udp = 10000
    [[2691]]
        image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
        idlepc = 0x60d94004
        ghostios = True
    [[ROUTER R4]]
        model = 2691
        console = 2003
        cnfg = configs\R4.cfg
        wic0/0 = WIC-2T
        wic0/1 = WIC-2T
        s0/0 = R2 s0/1
        s0/1 = R3 s0/1
        s0/2 = R5 s0/0
        x = -52.0
        y = -14.0
    [[ROUTER R1]]
        model = 2691
        console = 2000
        cnfg = configs\R1.cfg
        wic0/0 = WIC-2T
        wic0/1 = WIC-2T
        s0/0 = R2 s0/0
        s0/1 = R3 s0/0
        x = -172.0
        y = -149.0
    [[ROUTER R2]]
        model = 2691
        console = 2001
        cnfg = configs\R2.cfg
        wic0/0 = WIC-2T
        s0/0 = R1 s0/0
        s0/1 = R4 s0/0
        x = -186.0
        y = -14.0
    [[ROUTER R3]]
        model = 2691
        console = 2002
        cnfg = configs\R3.cfg
        wic0/0 = WIC-2T
        s0/0 = R1 s0/1
        s0/1 = R4 s0/1
        x = -42.0
        y = -152.0
[127.0.0.1:7201]
    workingdir = working
    udp = 10100
    [[2691]]
        image = D:\IOS\c2691-entservicesk9-mz.124-13b.bin
        idlepc = 0x60d94004
        ghostios = True
    [[ROUTER R5]]
        model = 2691
        console = 2004
        cnfg = configs\R5.cfg
        wic0/0 = WIC-2T
        s0/0 = R4 s0/2
        x = 163.0
        y = -162.0
[GNS3-DATA]
    configs = configs
    workdir = working
    [[NOTE 1]]
        text = AS6500
        x = 181.0
        y = -67.0
    [[NOTE 2]]
        text = AS 5500
        x = -163.0
        y = 127.0
    [[NOTE 3]]
        text = s0/0
        x = 1.84437745212
        y = 47.0863943933
        interface = R5 s0/0
    [[NOTE 4]]
        text = s0/2
        x = 64.1556225479
        y = -3.08639439326
        interface = R4 s0/2
    [[NOTE 5]]
        text = s0/1
        x = 30.6084915706
        y = -17.9284445907
        interface = R4 s0/1
    [[NOTE 6]]
        text = s0/0
        x = -6.63157210916
        y = 27.4165018376
        interface = R4 s0/0
    [[NOTE 7]]
        text = s0/1
        x = 35.3915084294
        y = 61.9284445907
        interface = R3 s0/1
    [[NOTE 8]]
        text = s0/0
        x = -6.47356356195
        y = 28.4682130238
        interface = R3 s0/0
    [[NOTE 9]]
        text = s0/1
        x = 72.6315721092
        y = 16.5834981624
        interface = R2 s0/1
    [[NOTE 10]]
        text = s0/0
        x = 31.7593438286
        y = -17.9807550237
        interface = R2 s0/0
    [[NOTE 11]]
        text = s0/1
        x = 72.473563562
        y = 15.5317869762
        interface = R1 s0/1
    [[NOTE 12]]
        text = s0/0
        x = 34.2406561714
        y = 61.9807550237
        interface = R1 s0/0
    [[SHAPE 1]]
        type = ellipse
        x = -208.0
        y = -192.0
        width = 263.0
        height = 296.0
        border_style = 2
        z = -2.0

R1 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.1 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.13.1 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.1.0.0 0.0.255.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 5500
 neighbor 4.4.4.4 update-source Loopback1
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R2 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.12.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.24.1 255.255.255.0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R3 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.13.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.34.1 255.255.255.0
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 10.1.0.0 0.0.255.255 area 0
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R4 config
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback4
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.24.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.34.2 255.255.255.0
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.45.1 255.255.255.0
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 10.1.0.0 0.0.255.255 area 0
!
router bgp 5500
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 5500
 neighbor 1.1.1.1 update-source Loopback4
 neighbor 5.5.5.5 remote-as 6500
 neighbor 5.5.5.5 ebgp-multihop 5
 neighbor 10.1.45.2 remote-as 6500
 no auto-summary
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

R5 config

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback5
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.45.2 255.255.255.0
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router bgp 6500
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.45.1 remote-as 5500
 no auto-summary
!
ip route 4.4.4.4 255.255.255.255 10.1.45.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

12 comments:

  1. PGMP will be also referred to as challenge supervision professional this also accreditation is made for the particular challenge administrators being employed by companies (any level). PgMP is just about the useful certification which are granted simply by Task Management Company (PMI).

    ReplyDelete
  2. hi admin
    when you have to learn about the field of networking and you have no idea how you can start then must start to read your blog funny videos If anyone feel bore and no idea how he can make happy then must visit this site.

    ReplyDelete
  3. Hello admin,
    This is sarmad sultan. i have read this article and i have seen that you have many informative thing on this blog. pregnancy ultrasound 6 weeks Well, i was searching for some pregnancy ultrasound 6 weeks.

    ReplyDelete
  4. Hey admin
    I read your post about basic BGP lab files per cbt nugget Jeremy 642-902.The information you provide in this article is really good. Your way of communication is simple and useful. Along with this I was searching for kitten pictures for my school project and I hope Good pictures i will find.
    Thanks for sharing this.

    ReplyDelete
  5. Hello admin,
    Thanks for sharing this information with us and i want to tell one thing i can't understand the whole thing.
    But it makes sense about that topic.
    Knowledgeadventure.com Games

    ReplyDelete
  6. Hey,
    Your blog have much descriptions related to your field i would be looking forward to your blog for more details.Well read latest Pakistan Urdu news for breaking news of this globe with many entertaining articles and blogs of famous writers.

    ReplyDelete
  7. Your web publication have a lot descriptions concerning your field i might be watching forward to your blog for more details.Well learn modern day Pakistan Urdu watch online movies
    information for breaking news of this globe with many wonderful articles and blogs of noted writers.

    ReplyDelete
  8. Admin i want to appreciate you by your effort its simply great work and i like it very much. it is good resource international urdu news paper

    ReplyDelete
  9. This comment has been removed by the author.

    ReplyDelete
  10. Article concerning the foodstuff will be good to read, even once you are feel hungry. Inside my point of opinion couple nations. Like notably Pakistan and India have experience and howto food.
    The CV & Resume Templates

    ReplyDelete
  11. You can find desi celebrities biography here, new desi updates
    desirulez
    Buy lawn suits replica of all brandes , Pakistani dresses in low prices
    Pakistani dresses
    The latest bollywood most emotional song ever you seen
    Amy Virk

    ReplyDelete
  12. helo sir
    you know at this time COVID 19 causes is most increase all over the world so I write an informative article about this Coronavirus Current Situation In Pakistan

    ReplyDelete